RBS SAMPLE Configuration help

Mar 25, 2011 at 8:08 AM

Hi

we have a requirement where we need to establish RBS on SQL server with remote storage solution(i.e. NAS,CAS etc.).

to achieve this task i followed the following article about installing RBS withFILESTREAM Provider

http://technet.microsoft.com/en-us/library/ee663474.aspx

By following this i was able to store BLOBS to SQL Server Local disk(i.e. D:\Blobstore) successfully.

now as i mentioned instead of storing BLOBs to SQL Server i want to store it to other remote storages. for that i followed following links

1.RBS installation without FILESTREAM Provider

http://technet.microsoft.com/en-us/library/ff628969.aspx

2.RBS sample at Codeplex

http://sqlrbs.codeplex.com/

here are the steps i followed

  • I created Sharepoint site with ContentDb.
  • Installed RBS on DB Server and Web Server using RBS.MSI from SQL feature pack

          during RBS installation i used my ContentDb as a targetDb. and Default option for    Filegroup

  • i tried to install provider using steps given at Codeplex RBS page. that showed provider installed properly. I checked ContentDb for provider entries. In that i found a table rbs_internal_blobs with blobstore entry.

When i tried to store a document into document library in my sharepoint website ,there was no RBS folder created at the location specified for BLOBstroe(i.e. D:\BLOBstore) during Codeplex sample Provider installation.

i am not able to trace the flaw in the configuration.

can please anyone help me with this?

thanks 

Mar 26, 2011 at 5:40 AM
Edited Jun 23, 2013 at 11:19 AM
i finally figured it out. with the help of Waqas-Microsoft Community Contributer 

after enabling RBS provider to Sharepoint i didnt set it as active provider...
i just ran following commands and it did work..

$cdb = Get-SPContentDatabase -WebApplication http://SiteName$rbss = $cdb.RemoteBlobStorageSettings

$rbss.Installed()

$rbss.Enable()

$rbss.SetActiveProviderName($rbss.GetProviderNames()[0])

$rbss


regards.
Sep 19, 2012 at 1:12 AM

That didn't work for me. I keep getting the co-relation ID error when I try to upload the file thru Sharepoint.

 

The only thing I differently was to enable on a new content database that I created with the following command

$cdb = Get-SPContentDatabase -Site siteUrl
Sep 19, 2012 at 11:26 AM
Edited Sep 19, 2012 at 11:27 AM

do you have two different content database?